System emails delay
Incident Report for impact.com
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 19:18 UTC
Identified
We have identified that some systems emails are currently not being delivered. We are working with our 3rd party provider to resolve this as soon as possible. Emails will be delivered once the issue is resolved.

Thank you for your patience. Please subscribe for updates by clicking the "Subscribe to Updates" button on our status page, status.impact.com.
Posted Apr 23, 2024 - 17:49 UTC
This incident affected: System Emails.