General Reporting Delay

Incident Report for impact.com

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 18:20 UTC

Monitoring

The initial issue has been identified and fix and we are monitoring the results.
Posted Jun 26, 2025 - 14:15 UTC

Identified

We're currently experiencing reporting delays, but tracking is unaffected.

We are investigating the issue and will provide an update as quickly as possible.
Posted Jun 26, 2025 - 11:22 UTC
This incident affected: Reporting.