Data Lab Maintenance

Incident Report for impact.com

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 21:15 UTC

Investigating

We are currently rolling out a new version of Data Lab. During this deployment, users may experience intermittent behavior. We appreciate your patience and understanding as we complete the release.
Posted Jun 25, 2025 - 21:09 UTC
This incident affected: Reporting.