General Reporting Incident - Report taking longer to load

Incident Report for impact.com

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 22:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2025 - 21:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 19:03 UTC

Investigating

Reports are taking longer to load than expected.

We are investigating the issue and will provide an update as quickly as possible.

Tracking is unaffected.
Posted Jul 08, 2025 - 18:10 UTC
This incident affected: Reporting.