General Platform Incident- Resolved

Incident Report for impact.com

Resolved

The platform disruptions have been resolved by the upstream provider. We apologize for any inconvenience.

Should you continue to experience anything out of the ordinary please contact our Customer Solutions team (Need Help? > Tickets).
Posted Dec 05, 2025 - 09:46 UTC

Monitoring

The upstream provider has implemented a fix to resolve the platform disruptions and we are monitoring the results.
Posted Dec 05, 2025 - 09:28 UTC

Identified

We're currently experiencing platform session disruptions. We have identified the issue and we’re working with the upstream provider.
Posted Dec 05, 2025 - 09:19 UTC

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 09:12 UTC

Investigating

We're currently experiencing platform session disruptions. We are investigating the issue and will provide an update as quickly as possible.
Posted Dec 05, 2025 - 08:58 UTC
This incident affected: Platform Web Portal, Platform API, and Marketing Website.